Ads Top

Algoritmos feitos no Vizualg - Execicios

Muitos algoritmos feitos usando o visualg, o intuito é para acelerar seu aprendizado e tirar aquela duvida.

Cacluladora de circuferência visualg

algoritmo "cacluladora de circuferência visualg"
// Função : cacluladora de circuferência visualg
// www.blogdokdsti.com.br
// Autor : Klebes
// Data : 03/06/2015
var
raio,resul:real
inicio
escreva("Digite o raio da circunferência: ")
leia(raio)
resul<- quad(raio)*pi
escreval("Área = ",resul)
fimalgoritmo

Ou baixe o algoritmo:  

 

Verificar-qual-o-maior-valor-e-sua-posicao-visualg

algoritmo "verificar-qual-o-maior-valor-e-sua-posicao"
// Função : verificar-qual-o-maior-valor-e-sua-posicao-visualg
// www.blogdokdsti.com.br
// Autor : Klebes
// Data : 03/06/2015
var
n1,n2: real
inicio
Escreva("Digite o 1° valor :")
Leia(n1)
Escreva("Digite o 2° valor :")
Leia(n2)
Se (n1 > n2) entao
   Escreval(" O maior valor é o 1° =",n1)
Senao
   Escreval(" O maior valor é o 2° =",n2)
FimSe
fimalgoritmo

Ou baixe o algoritmo:
Google Drive
Dropbox


Algoritmo-para-ler-e-escrever-um-valor-visualg

algoritmo "algoritmo-para-ler-e-escrever-um-valor"
// Função : algoritmo-para-ler-e-escrever-um-valor-visualg
// www.blogdokdsti.com.br
// Autor : Klebes
// Data : 03/06/2015
var
v: inteiro
inicio
Escreva("Digite um valor :")
Leia(v)
Se (v>3) entao
   Escreval("valor =",v)
Senao
   Escreval("Valor menor que 3")
FimSe
fimalgoritmo

Ou baixe o algoritmo:
Google Drive
Dropbox


Função : numero-referente-ao-mes-visualg

algoritmo "numero-referente-ao-mes"
// Função : numero-referente-ao-mes-visualg
// www.blogdokdsti.com.br
// Autor : Klebes
// Data : 03/06/2015
var
num: inteiro
inicio
escreval("Digite um número referente ao mês:")
escreva("Valor: ")
leia(num)

escolha(num)
caso 1
     escreval("Mês: Janeiro")
caso 2
     escreval("Mês: Fevereiro")
caso 3
     escreval("Mês: Março")
caso 4
     escreval("Mês: Abril")
caso 5
     escreval("Mês: Maio")
caso 6
     escreval("Mês: Junho")
caso 7
     escreval("Mês: Julho")
caso 8
     escreval("Mês: Agosto")
caso 9
     escreval("Mês: Setembro")
caso 10
     escreval("Mês: Outubro")
caso 11
     escreval("Mês: Novembro")
caso 12
     escreval("Mês: Dezembro")
outrocaso
     escreval("Mês inválido")
     fimescolha
fimalgoritmo

Ou baixe o algoritmo:
Google Drive
Dropbox


Algororitmo-sobremesa-visualg

algoritmo "www.blogdokdsti.com.br"
// Função : algoro-sobremesa-visualg
// www.blogdokdsti.com.br
// Autor : Klebes
// Data : 03/06/2015
var
opc,contador:inteiro
Inicio
Escreval("|==============================|")
Escreval("|       MENU DE SOBREMESAS     |")
Escreval("|==============================|")
Escreval("      ||                ||      ")
Escreval("      ||                ||      ")
Escreval("|=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-|")
Escreval("|  1 -> Mouse                  |")
Escreval("|  2 -> Sorvete                |")
Escreval("|  3 -> Milkshake              |")
Escreval("|  4 -> Sunday                 |")
Escreval("|=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-|")
Escreval()
repita
Escreval("Para pedir a sobremesa, você só precisa digitar o número desejado e aguardar!")
Escreva("Qual número vc deseja :")
Leia(opc)
Escolha(opc)
Caso 1
   Escreval("Mouse saindo por favor aguarde...")
   contador<-0
Caso 2
   Escreval("Sorvete saindo por favor aguarde...")
   contador<-0
Caso 3
   Escreval("MilkShake saindo por favor aguarde...")
   contador<-0
Caso 4
   Escreval("Sunday saindo por favor aguarde...")
   contador<-0
outrocaso
   escreval("Por favor escolha um valor válido!!")
   contador<-1
FimEscolha
ate(contador<>1)


fimalgoritmo

Ou baixe o algoritmo:
Google Drive
Dropbox 



Em breve mais algoritmos galera feitos no visualg

Nenhum comentário:

Tecnologia do Blogger.